Breach right now?

PHP + WordPress stack breach guide

Published 4 Nov 2026 · Updated 2026-11-04

If your website runs WordPress on PHP, update WordPress to 7.1.4 or later and PHP to a patched supported release (8.2.35, 8.3.36, 8.4.27 or 8.5.12 or later) now. Both have vulnerabilities that CISA lists as actively exploited in 2026, several allowing an attacker to run code on your server without logging in.

Who this is for: Australian small businesses, clinics, professional services and agencies running a WordPress site on PHP hosting. Written by our collective of Melbourne web and app developers; facts checked against NVD, the CISA KEV catalog and vendor advisories on 2026-11-04. Free to use and share.

Book a free stack check Already breached? First steps

Supported versions

PHP

BranchActive supportSecurity support until
8.1 and older—End of life
8.22024-12-312026-12-31
8.32025-12-312027-12-31
8.42026-12-312028-12-31
8.52027-12-312029-12-31

Source: PHP official lifecycle (checked 2026-11-04).

WordPress

WordPress does not publish fixed end-of-life dates per branch. The project recommends running the latest release (7.1.4 at the time of writing, released 28 October 2026); security fixes are sometimes backported to older branches, but only the current release is fully supported.

BranchActive supportSecurity support until
7.1Current release (7.1.4)Supported
7.0 and older—Backports only, at the project's discretion

Source: WordPress official lifecycle (checked 2026-11-04).

Key high and critical CVEs for this stack

These are recent high or critical vulnerabilities. "KEV" means CISA lists it as known to be exploited in the wild.

CVEComponentAffectedFixed inCVSSKEV
CVE-2026-109618PHP: Out-of-memory handling memory corruption leading to unauthenticated remote code execution5.x/7.3 up to 8.2.34, 8.3.0–8.3.35, 8.4.0–8.4.26, 8.5.0–8.5.11 (7.3.0+ per NVD)8.2.35, 8.3.36, 8.4.27, 8.5.129.2 (CVSS 4.0, PHP)Yes (added 2026-10-26)
CVE-2026-109619PHP: Stale internal request state leading to unauthenticated remote code execution5.4.0 up to 8.2.34, 8.3.0–8.3.35, 8.4.0–8.4.26, 8.5.0–8.5.118.2.35, 8.3.36, 8.4.27, 8.5.129.2 (CVSS 4.0, PHP)Yes (added 2026-10-26)
CVE-2024-4577PHP: PHP-CGI argument injection on Windows (Apache + PHP-CGI, certain code pages)8.1 before 8.1.29, 8.2 before 8.2.20, 8.3 before 8.3.88.1.29, 8.2.20, 8.3.89.8 (CVSS 3.1, PHP)Yes (added 2024-06-12)
CVE-2026-119977WordPress: Upgrade-window race condition (predictable staging paths) allowing unauthenticated code execution4.7 through 7.1.37.1.48.1 (CVSS 3.1, Wordfence)Yes (added 2026-11-03)
CVE-2026-87902WordPress: Page-template resolution local .php file inclusion, can lead to remote code executionAll branches before 4.7.37 … 6.9.9, 7.0.6, 7.1.2 (see NVD for each branch)7.1.2 (and branch backports such as 6.9.9, 6.8.10)8.1 (CVSS 3.1, CNA)Yes (added 2026-09-25)
CVE-2026-63030WordPress: REST API batch endpoint route confusion; chained with CVE-2026-60137 (WP_Query author__not_in SQL injection, CVSS 5.9) for remote code execution6.9.x before 6.9.5, 7.0.x before 7.0.26.9.5, 7.0.29.8 (CVSS 3.1, WPScan)Yes (added 2026-07-21)

How attacks on this stack typically work

  • Automated bots scan the internet for WordPress sites and read the version from public signals, then try known exploits within hours of a patch (Patchstack reported probing hours after the CVE-2026-87902 fix).
  • Unauthenticated remote code execution in PHP or WordPress core gives the attacker a web shell: they then add admin users, inject spam or card-skimming scripts, or copy the database.
  • Vulnerable plugins and themes are the most common entry point; core flaws such as CVE-2026-60137 become exploitable when a plugin passes untrusted input to core functions.
  • Stolen or reused admin passwords and exposed wp-login.php / XML-RPC endpoints are brute-forced.

Patch and hardening steps

  1. Find your exact versions. In WordPress, Tools → Site Health → Info shows WordPress and PHP versions; Plugins lists each plugin version.
  2. Back up first (files and database), and keep the backup off the server.
  3. Update PHP to at least: 8.2.35, 8.3.36, 8.4.27, 8.5.12; 8.1.29, 8.2.20, 8.3.8. Move off any end-of-life branch.
  4. Update WordPress to at least: 7.1.4; 7.1.2 (and branch backports such as 6.9.9, 6.8.10); 6.9.5, 7.0.2. Move off any end-of-life branch.
  5. Remove unused plugins, apps, themes and accounts, and turn on automatic updates for minor and security releases where available.
  6. Lock down admin: unique passwords, multi-factor authentication for every admin, and restrict wp-admin and XML-RPC where possible (WordPress hardening guide).
  7. Check for signs of compromise after patching a KEV-listed flaw: unknown admin users, unexpected new files on the server, changed checkout or header scripts.
  8. Follow a patching cadence. The ACSC's Essential Eight treats patching applications as a core mitigation.

What this means for your industry

Healthcare clinics, allied health, legal and accounting practices often run a CMS such as WordPress or Silverstripe for bookings and enquiry forms, which collect sensitive personal information. A compromise can become a notifiable data breach: see data breach help for Australian businesses. Industry-specific guides are coming.

Melbourne or Victorian public-sector supplier? See Melbourne and Victorian breach contacts. We will cover reported incidents involving these technologies in our Australian breach news.

Want a second pair of eyes on your stack?

Book a short call and one of our developers will talk through your versions and patch plan. No pressure, no scare tactics.

Book a free stack check or request a review call.

Frequently asked questions

Which PHP versions are still supported?

According to php.net, PHP 8.2 and 8.3 receive security fixes only (until 31 Dec 2026 and 31 Dec 2027), and 8.4 and 8.5 are actively supported. PHP 8.1 and older are end of life. Source

Is my WordPress site affected by CVE-2026-119977?

NVD lists WordPress 4.7 through 7.1.3 as affected. WordPress 7.1.4 (28 October 2026) fixes it. CISA added it to the Known Exploited Vulnerabilities catalog on 3 November 2026. Source

Does my host patch PHP for me?

On managed WordPress hosting, usually yes, but on shared or self-managed servers you or your developer may need to change the PHP version in the control panel. Check the exact version in Tools → Site Health → Info → Server. Source

I think my site was already compromised. What first?

Contain it (take it offline or into maintenance, reset passwords), keep logs, report to the ACSC on 1300 CYBER1, and assess whether personal information was involved for the Notifiable Data Breaches scheme. Source

Related stack guides

Sources

General information only, not legal or professional advice. Versions and CVEs change quickly; always confirm against the vendor before acting.